Version update
Incident Report for Jobzmall
Resolved
This incident has been resolved.
Posted 7 months ago. Aug 30, 2018 - 11:56 PDT
Investigating
We have upgraded the version and introduced new features - bug fixes
Posted 7 months ago. Aug 30, 2018 - 11:56 PDT
This incident affected: api.jobzmall.com and www.jobzmall.com.