Upgrading Servers
Incident Report for Jobzmall
Resolved
This incident has been resolved.
Posted 6 months ago. Oct 02, 2018 - 14:54 PDT
Monitoring
We are doing a scheduled maintenance therefore it may have some slowed performance
Posted 6 months ago. Oct 02, 2018 - 14:38 PDT
This incident affected: api.jobzmall.com and www.jobzmall.com.