Version Update
Incident Report for Jobzmall
Resolved
This incident has been resolved.
Posted 19 days ago. Sep 03, 2019 - 21:29 PDT
Monitoring
We have upgraded the version and introduced new features and bug fixes!
Posted 19 days ago. Sep 03, 2019 - 18:01 PDT
This incident affected: api.jobzmall.com and www.jobzmall.com.