Version Update
Incident Report for Jobzmall
Resolved
This incident has been resolved.
Posted Aug 01, 2019 - 02:43 PDT
Monitoring
We have upgraded the version and introduced new features and bug fixes!
Posted Aug 01, 2019 - 02:16 PDT
This incident affected: api.jobzmall.com and www.jobzmall.com.