Version Update + System Enhancement
Incident Report for Jobzmall
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 05, 2019 - 17:24 PST
Monitoring
Performance might be affected. Updating version and server config
Posted about 2 months ago. Feb 05, 2019 - 14:23 PST
This incident affected: www.jobzmall.com.