Version Update
Incident Report for Jobzmall
Resolved
This incident has been resolved.
Posted 7 months ago. Dec 29, 2018 - 20:50 PST
Monitoring
We have upgraded the version and introduced new features and bug fixes!
Posted 7 months ago. Dec 29, 2018 - 18:10 PST
This incident affected: api.jobzmall.com and www.jobzmall.com.