Scheduled Maintenance
Incident Report for Jobzmall
Resolved
This incident has been resolved.
Posted Mar 13, 2019 - 11:41 PDT
Monitoring
You may experience outages, we apologize for the inconvenience.
Posted Mar 13, 2019 - 11:31 PDT
This incident affected: api.jobzmall.com and www.jobzmall.com.