Major Upgrade
Incident Report for Jobzmall
Resolved
This incident has been resolved.
Posted 5 months ago. Oct 10, 2018 - 14:14 PDT
Monitoring
Introducing major code updates, version upgrade and additional minor bug fixes!
Posted 5 months ago. Oct 10, 2018 - 11:23 PDT
This incident affected: api.jobzmall.com and www.jobzmall.com.